
General Notice

When using this document, keep the following in mind:

1. This document is confidential.  By accepting this document you acknowledge that you are bound 
by the terms set forth in the nondisclosure and confidentiality agreement signed separately and in 
the possession of SEGA.  If you have not signed such a nondisclosure agreement, please contact 
SEGA immediately and return this document to SEGA.

2. This document may include technical inaccuracies or typographical errors.  Changes are periodi-
cally made to the information herein; these changes will be incorporated in new versions of the 
document.  SEGA may make improvements and/or changes in the product(s) and/or the 
program(s) described in this document at any time.

3. No one is permitted to reproduce or duplicate, in any form, the whole or part of this document 
without SEGA’S written permission.  Request for copies of this document and for technical
information about SEGA products must be made to your authorized SEGA Technical Services 
representative.

4. No license is granted by implication or otherwise under any patents, copyrights, trademarks, or 
other intellectual property rights of SEGA Enterprises, Ltd., SEGA of America, Inc., or any third 
party.

5. Software, circuitry, and other examples described herein are meant merely to indicate the 
characteristics and performance of SEGA’s products.  SEGA assumes no responsibility for any 
intellectual property claims or other problems that may result from applications based on the 
examples described herein.

6. It is possible that this document may contain reference to, or information about, SEGA products 
(development hardware/software) or services that are not provided in countries other than Japan.  
Such references/information must not be construed to mean that SEGA intends to provide such 
SEGA products or services in countries other than Japan.  Any reference of a SEGA licensed prod-
uct/program in this document is not intended to state or imply that you can use only SEGA’s 
licensed products/programs.  Any functionally equivalent hardware/software can be used instead.

7. SEGA will not be held responsible for any damage to the user that may result from accidents or any 
other reasons during operation of the user’s equipment, or programs according to this document.
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■ Introduction

The SpriteEditor takes in different types of graphic data as sprite data and
forms multiple sprites into patterns.

This document describes each function of the SpriteEditor.  Please refer to
SpriteEditor: Basic Operation for more details on the SpriteEditor.

■ Precautions

The SpriteEditor requires about 4 MB of memory at startup;  however, it
requires memory proportionate to the active editing size.  Use this
application after reserving enough memory for the application.

■ Supporting the PowerMac

The SpriteEditor operates in the PowerMac native mode.
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■ Supporting a Target

The following SEGA development target boxes work the SpriteEditor:

1. SATURN Target Model-S Graphics Box

2. SATURN Cartridge Development System (abbr. CartDev)

Please refer to the target manuals for precautions when connecting the
target box.

■ Windows

● Main Window

Displays a list of information on registered sprites and patterns.  Used
mainly to select sprites and patterns for editing purposes.
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● Pattern Edit Window

Use this window to change the positions of sprites.  Select a pattern
from the Main window to display it in the Pattern Edit window.

● Pattern Information Window

Displays the offset coordinate, information on horizontal or vertical
flip, coordinates for the center of rotation, rotation angle, etc., for each
sprite that is registered with a pattern.

Use this window to modify the registered order (=display priority) or to
set the center of rotation.
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● Import Window

Use the Import window to cut sprites out of graphic data.

● Sprite Window

Displays the cut sprite image.  Double-click to display a sprite listed in
the main window.
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■ Menus

◆ File Menu

● New (CommandN)

Reserves a new register area.

● Open... (CommandO)

Opens a file saved in this tool.

● Close (CommandW)

Closes the window that is currently being edited.

● Save... (CommandS)

Saves the data currently being edited.

● Save As...

Saves the data currently being edited under another name.

● Import...

Reads the graphic data file for sprite registration.

● Export...

Saves registered sprites individually in DGT2 format.

● Background...

Reads background image data.
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● Preferences

· H Base Unit, V Base unit

Snaps the base position of the selection to the specified pixel unit.

· H Width Unit, V Width Unit

Snaps the sprite selection size to the specified pixel unit.

· 1 pixel grid, 8 pixel grid

Set the size of the grid that is displayed when "Show Grid" is selected
from the Option menu.

· Center Line

Check this box off to display the center of the pattern displayed in the
Pattern Edit window.

· Background Color

Select the background color used in the Pattern Edit window.

· Previous Pattern Color

Select the silhouette color used for "Show Previous Pattern" under
the Option menu.
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● Quit (CommandQ)

Ends SpriteEditor.

◆ Edit Menu

● Undo (CommandZ)

● Cut (CommandX)

● Copy (CommandC)

● Paste (CommandV)

● Delete

● Select All (CommandA)

● De-select (CommandD)

◆ Option Menu

● Zoom (Command1, Command2, Command4, Command8)

Sets magnification for the Import and Pattern Edit windows.

● Show Grid (CommandG)

Displays or removes grids in the Import and Pattern Edit windows.

● Show Sprite Border

Displays sprite borders in the Import and Pattern Edit windows.

● Show Previous Pattern

Displays the previous pattern in the Pattern Edit window.
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● Set Background

Use this dialog box to set a background image that has already been
read in.  Select "Show" to display the image in the Pattern Edit
window or "Don't Show" to keep it from being displayed.  Drag the
background image to change the position it is displayed on the
Pattern Edit window.

● Set Monitor

Sets the display image to the target.  Select "Show Center Lines" to
display lines that indicate pattern origin.
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● Set Animation

Sets animation data and also gives playback instructions to the target.

◆ Pattern Menu

● New Pattern (CommandK)

Adds a new pattern register area.

● Select Sprite

Selects a sprite in a pattern.
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● Previous Pattern (CommandF)

Moves back to the previous pattern for editing purposes.

● Next Pattern (CommandR)

Moves to the next pattern for editing purposes.

● H Flip

· Origin:

Flips (left/right) selected sprites at the pattern origin.

· Sprite Center:

Flips (left/right) each selected sprite that is displayed in the Pattern
Edit window.

● V Flip

· Origin:

Flips (up/down) selected sprites at the pattern origin.

· Sprite Center:

Flips (up/down) each selected sprite that is displayed in the Pattern
Edit window.

◆ Window Menu

● Pattern Edit Window

Opens a Pattern Edit window.

● Pattern Information Window (CommandI)

Opens a Pattern Information window.

■ Restrictions

● A maximum of 32 windows can be opened at one time.

● Up to 255 sprites can be registered.

● Up to 255 patterns can be added.

● A maximum of 255 sprites can be set in a pattern.

● Up to 255 banks can be registered for animation.

● A maximum of 255 patterns can be registered in a bank.

● A target is necessary in order to display the results of the rotation and
animation functions.
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■ Startup

Be sure to connect the target machine to the Macintosh before starting up
the SpriteEditor.

Select a target from the following dialog box at startup.

To use a target, select a monitor mode from the popup menu and select
"OK".  When a target is not used, select "Discard".

■ Registering Sprites

Select "New" from the File menu to display the Main window.  This
window is used to display registered data.

Select "Import" from the File menu to read graphic data.
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The following dialog box is displayed if the graphic data uses a palette.

Set the palette address, palette mode, and replace palette, etc. in this dialog
box.  The graphic data is read after these functions are set.

To import many files at once, select the files in Finder and drag and drop
into the SpriteEditor icon.  The Palette Registration dialog box appears as
shown below:

Select "All" to set all of the files using the same settings.  Select "Next" to
set each file individually.
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An Import window displays the graphic data from the imported file.  To
register a sprite, drag on a desired area in the window.  The dragged area is
cut and registered as a sprite.  Information regarding each of the registered
sprites is displayed in the Main window.

To cut and move a registered sprite, click and drag the sprite in the Import
window.

To modify the size of the cut area, select the sprite, then drag the bottom-
right corner to the desired size.
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■ Deleting Sprites

To delete a registered sprite, select the sprite from the Main window or
the Import window.  Then, select "Cut" from the Edit menu or use the
Delete key.

■ Changing the Order of Registered Sprites

To change the order of the registered sprites, click and drag a sprite to the
desired location in the Main window.
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■ Sprite Output

The following describes how to output individual registered sprites as
DGT2 format image data.

Select "Export" from the File menu to display the following dialog box:

Click and select the sprite for output.

Click again to cancel that selection.

Make selections for "Output File".  Select "Default" to output under
automatically generated sprite names all at once.  Select "Custom" to
change each output filename.

Next, specify the folder in which to output the sprites.

If "Default" is selected, all sprites are output at once in the selected folder.
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■ Data Formats of Patterns

A pattern consists of positional information on multiple sprites.  The two
types of positional information are described below.

1. Data used to generate patterns from standard sprites

The pattern is represented by the relative coordinates from the "origin"
of the pattern to each of the sprite vertices.

2. Data used to generate patterns that have rotated sprites 

Designates a center for each sprite.  The relative coordinates of the
pattern origin and the sprite centers are used.  The pattern data consists
of the relative coordinates of the pattern origin and the sprite center
and the rotational angle data.

*It is not necessary to distinguish between the above types of data.  The output of saved
data is in both formats.

■ Registering Patterns

Select "New Pattern" from the Pattern menu to secure an area for pattern
editing.  Information is displayed in the Main window each time a new
pattern is added.

To edit a pattern, select the pattern from the Main window.  Next, select
"Pattern Edit" from the Window menu to display the Pattern Edit
window.
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The Pattern Edit window is also displayed when the pattern item in the
Main window is double-clicked.

Drag an icon from the sprite list into the Pattern Edit window.  This will
register the sprite to a pattern.

Once a sprite is registered to a pattern, click and drag it move the sprite in
the Pattern Edit window.
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If multiple sprites are positioned where clicked, the sprite that has the
highest priority is selected.

To move multiple sprites while maintaining their positional relationship,
select the sprites by dragging on the sprites.

Individual sprites may be added to a selection by using the key command,
SHIFT + click.

In order to maintain the positional relationship of the sprites from the
Import window to the Pattern Edit window, do the following.  First,
SHIFT + click to select the sprites in the Import window.  Then, copy
these sprites and paste them in the Pattern Edit window.
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The upper-left corner of the rectangular area that surrounds the sprites,
is registered as the offset coordinate (0,0) of the pattern.

Adjust this offset as necessary.



11

■ Modifying the Center of Rotation

When a sprite is registered to a pattern, the center is, by default, set to the
middle of the sprite.

To change the sprite center, double-click the sprite in the Pattern
Information window.  The following dialog box is displayed:

Drag the sprite or use the arrow buttons to move the center.  The
description of the coordinate values displayed are as follows:

SH: the relative value from the horizontal center coordinate to the
horizontal start coordinate.

SV: the relative value from vertical center coordinate to vertical start
coordinate.

EH: the relative value from horizontal center coordinate to horizontal
start coordinate.

EV: the relative value from vertical center coordinate to vertical start
coordinate.

Select "lock" to maintain the angles.
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■ Rotating Patterns

Select a sprite in the Pattern window and hold down the control key.  This
will rotate the pattern data.

The center of the sprite is indicated by lines during rotation.

Drag the selected area in this state to rotate the sprite.

When multiple sprites are selected, they are rotated with respect to one of
the central points.
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To change the center of rotation, select a sprite by holding down the
control key and clicking .  This changes the center of rotation to the center
of the selected sprite.

  Drag the sprites in the selected area, as in single sprites, to rotate multiple
sprites.
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*Confirm the rotation results in the target.  Only a clipped pseudo display of the rotation
results can be seen on the Macintosh.
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■ Flipping Patterns

Select a sprite to flip from the Pattern window and select "H Flip" or "V
Flip" from the Pattern menu.  There are two different ways to flip a sprite.

"Origin" flips the pattern at its origin.  This changes the positional
coordinates of the sprites.

"Sprite Center" flips each sprite while maintaining the same positional
coordinates.

■ Modifying Priorities

The display priority of registered patterns is in the order saved.  The more
recently a sprite was saved, higher the priority.

Follow the procedure described below to change the priority of a sprite.

Open the Pattern Information window by selecting "Pattern Information"
from the Window menu.

Click and drag the desired sprite to another location to change the order. 
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■ Copying Patterns

To copy patterns, select the pattern item from the Main window and copy
and paste.

To copy a portion of the positional information for a pattern, first, copy the
sprites in the Pattern Edit window, then, call the pattern to the active
window and paste.
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■ Moving the Pattern Origin

To move the pattern origin, place the cursor on the origin, horizontal or
vertical lines in the Pattern Edit window and drag to the desired
position.

The origin may also be changed by inputting a numerical value in
"Preferences" under the File menu.

*This  is a supplemental function for pattern editing.  Therefore, moving the origin does
not affect edit data.
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■ Set Background

Select "Background" from the File menu and read in background graphic
data.  The following dialog box is displayed.  To modify the display
position, drag the image displayed in the dialog box.

Select "Show" to display the background in the Pattern Edit window.  The
background is displayed in the specified position.

All settings can be modified by selecting "Set Background" from the
Option menu.

*"Background" is a supplemental function for pattern editing.  Therefore, modifying
settings does not affect the output data.
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■ Set Monitor

Select "Set Monitor" from the Option menu to display the following
dialog box.

Set the display position by dragging the inside of the displayed monitor
area.

Select "Show Center Lines" to display lines that indicate the pattern origin.

*This function is available for use only when a target is connected to the Macintosh.



20

■ Set Animation

Select "Set Animation" from the Option menu to display the following
dialog box.

Arrow button:

Selects the bank number to be edited.

Pattern list:

Sets the clicked list item in the lower input data area.  Also, a clicked
pattern is displayed on the target.

Entry:

If a list item is selected, the input data is saved in that position.  If an
item is not selected, the input data is saved on the list as an addition.

Insert:

Inserts input data in the selected list item.

Delete:

Deletes the selected list item.

Play:

Executes animation.

Stop:

Stops animation. (Clicking another item will also forcibly stop
animation.)

*This function is available for use only when a target is connected to the Macintosh.



SpriteEditor 1.2E:  Release Notes

■ Information on version upgrade from 1.0E→1.2E

◆ Now supports SATURN Target Model-S Graphics Box.

◆ The addition of "Replace All" function for sprite centers.

◆ A function to change the sprite palette is now available.

◆ The sprite display window is no longer available.

A dialog box for modifying the center and palette is now displayed when
a listed sprite is double-clicked.

◆ An addition timer has been added to the "Set Animation".

◆ Several problems have been eliminated.

■ Notes
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